NVDA 2019.3 is now live, however, pay attention before updating especially if you’re using remote!

Update: Note that NVDA Remote Support add-on version 2.3, for NVDA 2019.3 is now live. Go to nvdaremote.com to download it.

With the new release of NVDA, which is NVDA 2019.3, the core of this screen was migrated from Python 2 up to Python 3. Well, that’s great, but some NVDA add-on are not ready yet to be used with this version. When updating, you’ll be prompted to check the compatibility of all your add-on, and you may observe that some aren’t.

What you can do? First check if you’re running the latest version of each add-on you’re using. You can simplify this by downloading and installing Add-on Updater. Once done, please go into the tools menu and click search for add-on updates.

Note that if you’re using NVDA Remote Support add-on, there is currently no public compatible versions with NVDA 2019.3.

If you’re unable to update an essential add-on of if you’re relying on Remote to get assistance, wait before updating. You can still use NVDA 2019.2.1 without any issues.

If you’ve already updated your copy of NVDA to 2019.3 and need to use remote, note that you can use JAWS Tandem in replacement. If some other add-on stopped working, note that JAWS natively provides a lot of functions covered in NVDA add-ons.

You can always contact us to get a free quote if you need help with NVDA or want a private training.